Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found
Not Found

Submitted

Base Apparel coming soon page solution

Kyle Kasprzykā€¢ 260

@kylekasprzyk

Desktop design screenshot for the Base Apparel coming soon page coding challenge

This is a solution for...

  • HTML
  • CSS
  • JS
1newbie
View challenge

Design comparison


SolutionDesign

Solution retrospective


Hello šŸ‘‹,

This is my solution to the Base Apparel coming soon page challenge.

Thank you for taking the time to view my solution!

Community feedback

@0xabdulkhalid

Posted

Hello there šŸ‘‹. Congratulations on successfully completing the challenge! šŸŽ‰

  • I have other recommendations regarding your code that I believe will be of great interest to you.

JAVASCRIPT šŸŸ”:

  • The way you declared variables are need to be well structured and organized
  • Take a look at the following example code which describes a better way of declaring variables to have a well structured code
const firstName = "Your";
const lastName = "Name";
const emailAddress = "[email protected]";
const password = "supersecret";
  • instead try this,
const firstName =  "Your",
       lastName =  "Name",
       emailAddress = "[email protected]"
       ā€¢ā€¢ā€¢                
       ā€¢ā€¢ā€¢         // n number of declarations
       password = "supersecret";   // make sure to add a semicolon at end of last declaration
  • This single line declaration with separated commas will helps you to have a better structured code and improves readability though

.

I hope you find this helpful šŸ˜„ Above all, the solution you submitted is great !

Happy coding!

Marked as helpful

0

Kyle Kasprzykā€¢ 260

@kylekasprzyk

Posted

@0xAbdulKhalid,

Thank you for the feedback!

0

@VCarames

Posted

@0xAbdulKhalid

There really is no benefit to using this method especially performance wise; It is more of a preference. So by stating "better way of declaring variables to have a well structured code" is definitely incorrect āš ļø. As neither method is better than the other.

0

Please log in to post a comment

Log in with GitHub
Discord logo

Join our Discord community

Join thousands of Frontend Mentor community members taking the challenges, sharing resources, helping each other, and chatting about all things front-end!

Join our Discord